CVE-2025-14822
Fixed in a distro release EPSS <1%CVSS 3.1
Mattermost versions 10.11.x <= 10.11.8 fail to validate input size before processing hashtags which allows an authenticated attacker to exhaust CPU resources via a single HTTP request containing a post with thousands space-separated tokens
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 10.11.9 |
| Go | github.com/mattermost/mattermost-server | 11.2.0 |
| Go | github.com/mattermost/mattermost-server | 10.11.9+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.2.0+incompatible |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260226T182644-150000.1.149.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |