CVE-2025-14435
Fixed in a distro release EPSS <1%CVSS 6.8
Mattermost versions 10.11.x <= 10.11.8, 11.1.x <= 11.1.1, 11.0.x <= 11.0.6 fail to prevent infinite re-renders on API errors which allows authenticated users to cause application-level DoS via triggering unbounded component re-render loops.
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 10.11.9 |
| Go | github.com/mattermost/mattermost-server | 11.1.2 |
| Go | github.com/mattermost/mattermost-server | 11.0.7 |
| Go | github.com/mattermost/mattermost-server | 10.11.9+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.0.7+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.1.2+incompatible |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE:Leap 15.6 | govulncheck-vulndb | 0.0.20260226T182644-150000.1.149.1 |
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |