CVE-2025-13870
Fixed in a distro release EPSS <1%CVSS 3.1
Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to the block in Boards, which allows an authenticated user to access other board files and was able to subscribe to the block from other boards that the user does not have access to
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost | 10.11.5 |
| Go | github.com/mattermost/mattermost | 10.5.13 |
| Go | github.com/mattermost/mattermost | 10.5.13+incompatible |
| Go | github.com/mattermost/mattermost | 10.11.5+incompatible |
| Go | github.com/mattermost/mattermost-server | no fix |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20250905150616-ba86dfc5876b |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20251212204551-54f2e9b4afd5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE:Linux Enterprise Module for Package Hub 15 SP6 | govulncheck-vulndb | 0.0.20251209T172047-150000.1.127.1 |
| openSUSE:Leap 15.6 | govulncheck-vulndb | 0.0.20251209T172047-150000.1.127.1 |
| openSUSE:Leap 15.6 | govulncheck-vulndb | 0.0.20251230T014957-150000.1.134.1 |
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |