CVE-2025-13352
Fixed in a distro release EPSS <1%CVSS 3.0
Mattermost versions 10.11.x <= 10.11.6 and Mattermost GitHub plugin versions <=2.4.0 fail to validate plugin bot identity in reaction forwarding which allows attackers to hijack the GitHub reaction feature to make users add reactions to arbitrary GitHub objects via crafted notification posts.
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost | 10.11.7-0.20251106103514-3b05384dd014 |
| Go | github.com/mattermost/mattermost | 11.1.0 |
| Go | github.com/mattermost/mattermost | 11.1.0+incompatible |
| Go | github.com/mattermost/mattermost-plugin-github | 1.0.1-0.20250829075715-0deffcfc6bee |
| Go | github.com/mattermost/mattermost-server | no fix |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 10.11.7-0.20251106103514-3b05384dd014 |
| Go | github.com/mattermost/mattermost/server/v8 | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20251230T014957-150000.1.134.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |