CVE-2025-13324
Fixed in a distro release EPSS <1%CVSS 3.7
Mattermost versions 10.11.x <= 10.11.5, 11.0.x <= 11.0.4, 10.12.x <= 10.12.2 fail to invalidate remote cluster invite tokens when using the legacy (version 1) protocol or when the confirming party does not provide a refreshed token, which allows an attacker who has obtained an invite token to authenticate as the remote cluster and perform limited actions on shared channels even after the invitation has been legitimately confirmed.
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost | 10.12.2 |
| Go | github.com/mattermost/mattermost | 10.11.5 |
| Go | github.com/mattermost/mattermost | 11.0.4 |
| Go | github.com/mattermost/mattermost | 10.11.5+incompatible |
| Go | github.com/mattermost/mattermost | 10.12.2+incompatible |
| Go | github.com/mattermost/mattermost | 11.0.4+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.0.4 |
| Go | github.com/mattermost/mattermost-server | 11.0.4+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20251031095924-e7e23b94e006 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE:Leap 15.6 | govulncheck-vulndb | 0.0.20251230T014957-150000.1.134.1 |
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |