CVE-2025-12819
Fixed in a distro release EPSS <1%CVSS 7.5
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
Products: pgbouncer
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | pgbouncer | 1.25.1-r0 |
| Chainguard | pgbouncer-doc | 1.25.1-r0 |
| Chainguard | pgbouncer-iamguarded-compat | 1.25.1-r0 |
| Debian 11 | pgbouncer | 1.15.0-1+deb11u2 |
| Debian 12 | pgbouncer | 1.18.0-1+deb12u1 |
| Debian 13 | pgbouncer | 1.24.1-1+deb13u1 |
| Debian 14 | pgbouncer | 1.25.1-1 |
| Ubuntu 16.04 LTS | pgbouncer | no fix |
| Ubuntu 18.04 LTS | pgbouncer | no fix |
| Ubuntu 20.04 LTS | pgbouncer | no fix |
| Ubuntu 22.04 LTS | pgbouncer | no fix |
| Ubuntu 24.04 LTS | pgbouncer | no fix |
| Ubuntu 25.10 | pgbouncer | no fix |
| Ubuntu 26.04 LTS | pgbouncer | no fix |
| Wolfi | pgbouncer | 1.25.1-r0 |