CVE-2025-1215
Fixed in a distro release EPSS <1%CVSS 2.8
A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.
Products: vim, netapp bootstrap_os
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux 2 | vim-X11 | 2:9.0.2153-1.amzn2.0.4 |
| Amazon Linux 2 | vim-common | 2:9.0.2153-1.amzn2.0.4 |
| Amazon Linux 2 | vim-data | 2:9.0.2153-1.amzn2.0.4 |
| Amazon Linux 2 | vim-enhanced | 2:9.0.2153-1.amzn2.0.4 |
| Amazon Linux 2 | vim-filesystem | 2:9.0.2153-1.amzn2.0.4 |
| Amazon Linux 2 | vim-minimal | 2:9.0.2153-1.amzn2.0.4 |
| Amazon Linux 2 | xxd | 2:9.0.2153-1.amzn2.0.4 |
| Amazon Linux 2023 | vim-common | 2:9.1.1202-1.amzn2023.0.1 |
| Amazon Linux 2023 | vim-data | 2:9.1.1202-1.amzn2023.0.1 |
| Amazon Linux 2023 | vim-default-editor | 2:9.1.1202-1.amzn2023.0.1 |
| Amazon Linux 2023 | vim-enhanced | 2:9.1.1202-1.amzn2023.0.1 |
| Amazon Linux 2023 | vim-filesystem | 2:9.1.1202-1.amzn2023.0.1 |
| Amazon Linux 2023 | vim-minimal | 2:9.1.1202-1.amzn2023.0.1 |
| Amazon Linux 2023 | xxd | 2:9.1.1202-1.amzn2023.0.1 |
| Debian 12 | vim | no fix |
| Debian 13 | vim | 2:9.1.1113-1 |
| Debian 14 | vim | 2:9.1.1113-1 |
| SUSE Linux Enterprise Micro 5.1 | vim | 9.1.1101-150000.5.69.1 |
| SUSE Linux Enterprise Micro 5.2 | vim | 9.1.1101-150000.5.69.1 |
| SUSE Linux Enterprise Micro 5.3 | vim | 9.1.1101-150000.5.69.1 |
| SUSE Linux Enterprise Micro 5.4 | vim | 9.1.1101-150000.5.69.1 |
| SUSE Linux Enterprise Micro 5.5 | vim | 9.1.1101-150500.20.21.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | vim | 9.1.1101-150500.20.21.1 |
| SUSE Linux Enterprise Module for Desktop Applications 15 SP6 | vim | 9.1.1101-150500.20.21.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | vim | 9.1.1101-17.41.1 |
| SUSE Linux Micro 6.0 | vim | 9.1.1101-1.1 |
| Ubuntu 20.04 LTS | vim | 2:8.1.2269-1ubuntu5.32 |
| Ubuntu 22.04 LTS | vim | 2:8.2.3995-1ubuntu2.24 |
| Ubuntu 24.04 LTS | vim | 2:9.1.0016-1ubuntu7.8 |
| Ubuntu Pro 14.04 LTS | vim | 2:7.4.052-1ubuntu3.1+esm21 |
| Ubuntu Pro 16.04 LTS | vim | 2:7.4.1689-3ubuntu1.5+esm27 |
| Ubuntu Pro 18.04 LTS | vim | 2:8.0.1453-1ubuntu1.13+esm12 |
| openSUSE Leap 15.6 | vim | 9.1.1101-150500.20.21.1 |