CVE-2024-9014
Fixed in a distro release EPSS 10%CVSS 9.9
pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.
Products: pgadmin.org pgAdmin 4, postgresql pgadmin_4
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | pgadmin4 | 8.12 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Module for Python 3 15 SP6 | pgadmin4 | 8.5-150600.3.6.1 |
| openSUSE Leap 15.6 | pgadmin4 | 8.5-150600.3.6.1 |
| openSUSE Tumbleweed | pgadmin4 | 9.2-1.1 |