CVE-2024-8926
Fixed in a distro release EPSS 4%CVSS 8.1
In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using a certain non-standard configurations of Windows codepages, the fixes for CVE-2024-4577 https://github.com/advisories/GHSA-vxpp-6299-mxw3 may still be bypassed and the same command injection related to Windows "Best Fit" codepage behavior can be achieved. This may allow a malicious user to pass options to PHP binary being run, and thus reveal the source code of scripts, run arbitrary PHP code on the server, etc.
Products: PHP Group PHP, PHP
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | php8.2 | 8.2.24-1~deb12u1 |
| Ubuntu 20.04 LTS | php7.4 | no fix |
| Ubuntu 22.04 LTS | php8.1 | no fix |
| Ubuntu 24.04 LTS | php8.3 | no fix |
| Ubuntu Pro 14.04 LTS | php5 | no fix |
| Ubuntu Pro 16.04 LTS | php7.0 | no fix |
| Ubuntu Pro 18.04 LTS | php7.2 | no fix |