CVE-2024-7776
Fixed in a distro release EPSS 2%CVSS 8.1
A vulnerability in the `download_model` function of the onnx/onnx framework, before and including version 1.16.1, allows for arbitrary file overwrite due to inadequate prevention of path traversal attacks in malicious tar files. This vulnerability can be exploited by an attacker to overwrite files in the user's directory, potentially leading to remote command execution.
Products: onnx/onnx
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | onnx | 1.17.0 |
| PyPI | onnx | 1.16.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | onnx | no fix |
| Debian 13 | onnx | 1.16.2-1 |
| Debian 14 | onnx | 1.16.2-1 |
| Ubuntu 22.04 LTS | onnx | no fix |
| Ubuntu Pro 24.04 LTS | onnx | no fix |