Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-7272

Fixed in a distro release EPSS 1%CVSS 6.3

A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

Published 2024-08-08 · CVE record · OSV

Products: FFMPEG

Distro releases

ReleasePackageFixed in
Chainguardtorchaudio-ffmpeg-tarballsno fix
Chainguardtorchaudio-ffmpeg-tarballs-4.4.4no fix
Chainguardtorchaudio-ffmpeg-tarballs-5.0.3no fix
Chainguardtorchaudio-ffmpeg-tarballs-6.0no fix
Debian 12ffmpeg7:5.1.6-0+deb12u1
Debian 13ffmpeg7:6.0-4
Debian 14ffmpeg7:6.0-4
Ubuntu 24.04 LTSffmpeg7:6.0-6ubuntu1
openSUSE Tumbleweedffmpeg-55.1.4-11.1