CVE-2024-6307
Fixed in a distro release EPSS <1%CVSS 6.4
WordPress Core is vulnerable to Stored Cross-Site Scripting via the HTML API in various versions prior to 6.5.5 due to insufficient input sanitization and output escaping on URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Products: WordPress Foundation WordPress
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | wordpress | 5.7.14+dfsg1-0+deb11u1 |
| Debian 12 | wordpress | 6.1.9+dfsg1-0+deb12u1 |
| Debian 13 | wordpress | 6.5.5+dfsg1-1 |
| Debian 14 | wordpress | 6.5.5+dfsg1-1 |
| Ubuntu 16.04 LTS | wordpress | no fix |
| Ubuntu 18.04 LTS | wordpress | no fix |
| Ubuntu 20.04 LTS | wordpress | no fix |
| Ubuntu 22.04 LTS | wordpress | no fix |
| Ubuntu 24.04 LTS | wordpress | no fix |