Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-58375

Fixed upstream EPSS <1%CVSS 7.5

OpenTofu versions 1.8.0 through 1.8.2 do not properly restrict sensitive variables and locals when users have opted into static evaluation of module sources, versions, and backend configurations. As a result, values marked as sensitive may be exposed through these configuration elements instead of producing an error. This is fixed in OpenTofu 1.8.3, which adds explicit errors to prevent the use of sensitive values in these contexts.

Published 2026-08-16 · CVE record · OSV

Products: opentofu

Fixed upstream

EcosystemPackageFixed in
Gogithub.com/opentofu/opentofu1.8.3