CVE-2024-56378
Fixed in a distro release EPSS <1%CVSS 4.3
libpoppler.so in Poppler through 24.12.0 has an out-of-bounds read vulnerability within the JBIG2Bitmap::combine function in JBIG2Stream.cc.
Products: freedesktop poppler
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | poppler | 20.09.0-3.1+deb11u2 |
| Debian 12 | poppler | 22.12.0-2+deb12u1 |
| Debian 13 | poppler | 24.08.0-4 |
| Debian 14 | poppler | 24.08.0-4 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | poppler | 0.79.0-150200.3.35.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | poppler | 24.03.0-150600.3.5.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | poppler | 24.03.0-150600.3.5.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | poppler-qt5 | 24.03.0-150600.3.5.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | poppler-qt6 | 24.03.0-150600.3.5.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | poppler | 0.43.0-16.52.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | poppler-qt | 0.43.0-16.52.1 |
| Ubuntu 20.04 LTS | poppler | 0.86.1-0ubuntu1.5 |
| Ubuntu 22.04 LTS | poppler | 22.02.0-2ubuntu0.6 |
| Ubuntu 24.04 LTS | poppler | 24.02.0-1ubuntu9.2 |
| Ubuntu Pro 16.04 LTS | poppler | 0.41.0-0ubuntu1.16+esm5 |
| Ubuntu Pro 18.04 LTS | poppler | 0.62.0-2ubuntu2.14+esm4 |
| openSUSE Leap 15.5 | poppler | 23.01.0-150500.3.14.1 |
| openSUSE Leap 15.5 | poppler-qt5 | 23.01.0-150500.3.14.1 |
| openSUSE Leap 15.5 | poppler-qt6 | 23.01.0-150500.3.14.1 |
| openSUSE Leap 15.6 | poppler | 24.03.0-150600.3.5.1 |
| openSUSE Leap 15.6 | poppler-qt5 | 24.03.0-150600.3.5.1 |
| openSUSE Leap 15.6 | poppler-qt6 | 24.03.0-150600.3.5.1 |
| openSUSE Tumbleweed | poppler | 24.12.0-1.1 |