CVE-2024-55637
Fixed upstream EPSS <1%CVSS 9.8
Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8. Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so-called gadget chain presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.
Products: Drupal Core
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Packagist | drupal/core | 10.2.11 |
| Packagist | drupal/core | 10.3.9 |
| Packagist | drupal/core | 11.0.8 |
| Packagist | drupal/core-recommended | 10.2.11 |
| Packagist | drupal/core-recommended | 10.3.9 |
| Packagist | drupal/core-recommended | 11.0.8 |
| Packagist | drupal/drupal | 10.2.11 |
| Packagist | drupal/drupal | 10.3.9 |
| Packagist | drupal/drupal | 11.0.8 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu Pro 14.04 LTS | drupal7 | no fix |
| Ubuntu Pro 16.04 LTS | drupal7 | no fix |