CVE-2024-53382
Fixed in a distro release EPSS <1%CVSS 4.9
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
Products: PrismJS prism
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | prismjs | 1.30.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | kibana-8.19 | 8.19.3-r1 |
| Chainguard | kibana-8.19-bitnami | 8.19.3-r1 |
| Chainguard | kibana-8.19-iamguarded | 8.19.3-r1 |
| Chainguard | kibana-9.4 | 9.4.2-r1 |
| Chainguard | kibana-9.4-iamguarded | 9.4.2-r1 |
| Chainguard | opensearch-dashboards-2 | 2.19.4-r0 |
| Chainguard | opensearch-dashboards-2-dashboards-observability | 2.19.3-r0 |
| Chainguard | opensearch-dashboards-2-fips-dashboards-observability | 2.19.2-r4 |
| Debian:12 | node-prismjs | no fix |
| Debian:13 | node-prismjs | no fix |
| Debian:14 | node-prismjs | 1.30.0+dfsg+~1.26.5-1 |
| Ubuntu:20.04:LTS | node-prismjs | no fix |
| Ubuntu:22.04:LTS | node-prismjs | no fix |
| Ubuntu:24.04:LTS | node-prismjs | no fix |
| Ubuntu:25.10 | node-prismjs | no fix |
| Ubuntu:26.04:LTS | node-prismjs | no fix |
| Ubuntu:26.10 | node-prismjs | no fix |
| Wolfi | opensearch-dashboards-2 | 2.19.4-r0 |
| Wolfi | opensearch-dashboards-2-dashboards-observability | 2.19.3-r0 |