CVE-2024-48208
Fixed in a distro release EPSS 2%CVSS 8.6
pure-ftpd before 1.0.52 is vulnerable to Buffer Overflow. There is an out of bounds read in the domlsd() function of the ls.c file.
Products: pureftpd pure-ftpd
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | pure-ftpd | no fix |
| Debian 13 | pure-ftpd | no fix |
| Ubuntu 16.04 LTS | pure-ftpd | no fix |
| Ubuntu 18.04 LTS | pure-ftpd | no fix |
| Ubuntu 20.04 LTS | pure-ftpd | no fix |
| Ubuntu 22.04 LTS | pure-ftpd | no fix |
| Ubuntu 24.04 LTS | pure-ftpd | no fix |
| Ubuntu 25.10 | pure-ftpd | no fix |
| Ubuntu 26.04 LTS | pure-ftpd | no fix |
| openSUSE Tumbleweed | pure-ftpd | 1.0.51-5.1 |