CVE-2024-47888
Fixed in a distro release EPSS <1%CVSS 6.6
Action Text brings rich text content and editing to Rails. Starting in version 6.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the `plain_text_for_blockquote_node helper` in Action Text. Carefully crafted text can cause the `plain_text_for_blockquote_node` helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling `plain_text_for_blockquote_node` or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
Products: rails
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| RubyGems | actiontext | 6.1.7.9 |
| RubyGems | actiontext | 7.0.8.5 |
| RubyGems | actiontext | 7.1.4.1 |
| RubyGems | actiontext | 7.2.1.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | rails | 2:6.0.3.7+dfsg-2+deb11u3 |
| Debian 12 | rails | 2:6.1.7.10+dfsg-1~deb12u1 |
| Debian 13 | rails | 2:7.2.2.1+dfsg-1 |
| Debian 14 | rails | 2:7.2.2.1+dfsg-1 |
| Ubuntu 24.04 LTS | rails | no fix |
| Ubuntu 25.10 | rails | no fix |
| Ubuntu 26.04 LTS | rails | no fix |
| Ubuntu 26.10 | rails | no fix |
| Ubuntu Pro 16.04 LTS | rails | 2:4.2.6-1ubuntu0.1~esm1 |
| Ubuntu Pro 18.04 LTS | rails | 2:4.2.10-0ubuntu4+esm1 |
| Ubuntu Pro 20.04 LTS | rails | 2:5.2.3+dfsg-3ubuntu0.1~esm1 |
| Ubuntu Pro 22.04 LTS | rails | 2:6.1.4.1+dfsg-8ubuntu2+esm1 |
| openSUSE Tumbleweed | rubygem-actiontext-7.0 | 7.0.8.6-1.3 |
| openSUSE Tumbleweed | rubygem-actiontext-7.0 | 7.0.8.6-1.1 |
| openSUSE Tumbleweed | rubygem-rails-7.0 | 7.0.8.6-1.3 |
| openSUSE Tumbleweed | rubygem-rails-7.0 | 7.0.8.6-1.1 |