CVE-2024-47068
Fixed in a distro release EPSS <1%CVSS 6.1
Rollup is a module bundler for JavaScript. Versions prior to 2.79.2, 3.29.5, and 4.22.4 are susceptible to a DOM Clobbering vulnerability when bundling scripts with properties from `import.meta` (e.g., `import.meta.url`) in `cjs`/`umd`/`iife` format. The DOM Clobbering gadget can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an `img` tag with an unsanitized `name` attribute) are present. Versions 2.79.2, 3.29.5, and 4.22.4 contain a patch for the vulnerability.
Products: rollup
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | rollup | 3.29.5 |
| npm | rollup | 4.22.4 |
| npm | rollup | 2.79.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | arangodb-3.11 | 3.11.14.5-r9 |
| Chainguard | vite | 5.4.8-r0 |
| Chainguard | vitess-18 | 18.0.8-r16 |
| Chainguard | vitess-18-binaries | 18.0.8-r16 |
| Chainguard | vitess-18.0 | 18.0.8-r0 |
| Chainguard | vitess-18.0-binaries | 18.0.8-r0 |
| Debian 12 | node-rollup | no fix |
| Debian 13 | node-rollup | 3.29.5-1 |
| Debian 14 | node-rollup | 3.29.5-1 |
| Ubuntu 20.04 LTS | node-rollup | no fix |
| Ubuntu 22.04 LTS | node-rollup | no fix |
| Ubuntu 24.04 LTS | node-rollup | no fix |
| Ubuntu 25.10 | node-rollup | no fix |
| Ubuntu 26.04 LTS | node-rollup | no fix |
| Ubuntu 26.10 | node-rollup | no fix |
| Wolfi | vite | 5.4.8-r0 |
| openSUSE Tumbleweed | velociraptor | 0.7.0.4.git142.862ef23-1.1 |