CVE-2024-46461
Fixed in a distro release EPSS <1%CVSS 8.0
VLC media player 3.0.20 and earlier is vulnerable to denial of service through an integer overflow which could be triggered with a maliciously crafted mms stream (heap based overflow). If successful, a malicious third party could trigger either a crash of VLC or an arbitrary code execution with the target user's privileges.
Products: videolan vlc_media_player
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | vlc | 3.0.21-0+deb11u1 |
| Debian 12 | vlc | 3.0.21-0+deb12u1 |
| Debian 13 | vlc | 3.0.21-1 |
| Debian 14 | vlc | 3.0.21-1 |
| Ubuntu 22.04 LTS | vlc | no fix |
| Ubuntu 24.04 LTS | vlc | no fix |
| Ubuntu Pro 16.04 LTS | vlc | 2.2.2-5ubuntu0.16.04.5+esm4 |
| Ubuntu Pro 18.04 LTS | vlc | 3.0.8-0ubuntu18.04.1+esm3 |
| Ubuntu Pro 20.04 LTS | vlc | 3.0.9.2-1ubuntu0.1~esm3 |
| Ubuntu Pro 22.04 LTS | vlc | 3.0.16-1ubuntu0.1~esm3 |
| Ubuntu Pro 24.04 LTS | vlc | 3.0.20-3ubuntu0.1~esm1 |