CVE-2024-45498
Fixed in a distro release EPSS 1%CVSS 8.8
Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873 for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.
Products: Apache Software Foundation Apache Airflow, Apache Airflow
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | apache-airflow | 2.10.1 |
| PyPI | apache-airflow | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | airflow | 2.10.1-r0 |
| Wolfi | airflow | 2.10.1-r0 |