CVE-2024-45477
Fixed upstream EPSS <1%CVSS 4.6
Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.28.0 or 2.0.0-M4 is the recommended mitigation.
Products: Apache Software Foundation Apache NiFi
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.nifi:nifi-web-ui | 1.28.0 |
| Maven | org.apache.nifi:nifi-web-ui | 2.0.0-M4 |