Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-45217

Fixed upstream EPSS <1%CVSS 8.1

Insecure Default Initialization of Resource vulnerability in Apache Solr. New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized. This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization. Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.

Published 2024-10-16 · CVE record · OSV

Products: Apache Software Foundation Apache Solr

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.solr:solr8.11.4
Mavenorg.apache.solr:solr9.7.0

Distro releases

ReleasePackageFixed in
Ubuntu 20.04 LTSlucene-solrno fix
Ubuntu 22.04 LTSlucene-solrno fix
Ubuntu 24.04 LTSlucene-solrno fix
Ubuntu 25.10lucene-solrno fix
Ubuntu 26.04 LTSlucene-solrno fix
Ubuntu 26.10lucene-solrno fix
Ubuntu Pro 14.04 LTSlucene-solrno fix
Ubuntu Pro 16.04 LTSlucene-solrno fix
Ubuntu Pro 18.04 LTSlucene-solrno fix