CVE-2024-45216
Fixed upstream EPSS 93%CVSS 9.8
Improper Authentication vulnerability in Apache Solr. Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.
Products: Apache Software Foundation Apache Solr, Apache Solr
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.solr:solr | 8.11.4 |
| Maven | org.apache.solr:solr | 9.7.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 20.04 LTS | lucene-solr | no fix |
| Ubuntu 22.04 LTS | lucene-solr | no fix |
| Ubuntu 24.04 LTS | lucene-solr | no fix |
| Ubuntu 25.10 | lucene-solr | no fix |
| Ubuntu 26.04 LTS | lucene-solr | no fix |
| Ubuntu 26.10 | lucene-solr | no fix |
| Ubuntu Pro 14.04 LTS | lucene-solr | no fix |
| Ubuntu Pro 16.04 LTS | lucene-solr | no fix |
| Ubuntu Pro 18.04 LTS | lucene-solr | no fix |