CVE-2024-4215
Fixed in a distro release EPSS <1%CVSS 7.4
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
Products: pgadmin.org pgAdmin 4, postgresql pgadmin
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | pgadmin4 | 8.6 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Module for Python 3 15 SP6 | pgadmin4 | 8.5-150600.3.3.1 |
| openSUSE Leap 15.6 | pgadmin4 | 8.5-150600.3.3.1 |
| openSUSE Tumbleweed | pgadmin4 | 8.8-1.1 |