CVE-2024-4141
Fixed in a distro release EPSS <1%CVSS 2.9
Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid character code in a Type 1 font. The root problem was a bounds check that was being optimized away by modern compilers.
Products: xpdf
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Module for Basesystem 15 SP5 | poppler | 0.79.0-150200.3.29.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP5 | poppler | 23.01.0-150500.3.8.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | poppler | 0.79.0-150200.3.29.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP5 | poppler | 23.01.0-150500.3.8.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP5 | poppler-qt5 | 23.01.0-150500.3.8.1 |
| SUSE Linux Enterprise Server 12 SP5 | poppler | 0.43.0-16.46.1 |
| SUSE Linux Enterprise Server 12 SP5 | poppler-qt | 0.43.0-16.46.1 |
| SUSE Linux Enterprise Server for SAP Applications 12 SP5 | poppler | 0.43.0-16.46.1 |
| SUSE Linux Enterprise Server for SAP Applications 12 SP5 | poppler-qt | 0.43.0-16.46.1 |
| SUSE Linux Enterprise Software Development Kit 12 SP5 | poppler | 0.24.4-14.47.1 |
| SUSE Linux Enterprise Software Development Kit 12 SP5 | poppler | 0.43.0-16.46.1 |
| SUSE Linux Enterprise Software Development Kit 12 SP5 | poppler-qt | 0.43.0-16.46.1 |
| SUSE Linux Enterprise Workstation Extension 15 SP5 | poppler | 22.01.0-150400.3.19.1 |
| Ubuntu 16.04 LTS | ipe | no fix |
| Ubuntu 16.04 LTS | xpdf | no fix |
| Ubuntu 18.04 LTS | ipe | no fix |
| Ubuntu 18.04 LTS | xpdf | no fix |
| Ubuntu 20.04 LTS | ipe | no fix |
| Ubuntu 22.04 LTS | ipe | no fix |
| Ubuntu 22.04 LTS | xpdf | no fix |
| Ubuntu 24.04 LTS | ipe | no fix |
| Ubuntu 24.04 LTS | xpdf | no fix |
| Ubuntu 25.10 | ipe | no fix |
| Ubuntu 25.10 | xpdf | no fix |
| Ubuntu 26.04 LTS | ipe | no fix |
| Ubuntu 26.04 LTS | xpdf | no fix |
| Ubuntu 26.10 | ipe | no fix |
| Ubuntu 26.10 | xpdf | no fix |
| openSUSE Leap 15.5 | poppler | 23.01.0-150500.3.8.1 |
| openSUSE Leap 15.5 | poppler-qt5 | 23.01.0-150500.3.8.1 |
| openSUSE Leap 15.5 | poppler-qt6 | 23.01.0-150500.3.8.1 |