Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-41128

Fixed in a distro release EPSS 1%CVSS 6.6

Action Pack is a framework for handling and responding to web requests. Starting in version 3.1.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the query parameter filtering routines of Action Dispatch. Carefully crafted query parameters can cause query parameter filtering to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to version 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may use Ruby 3.2 as a workaround. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.

Published 2024-10-16 · CVE record · OSV

Products: rails

Fixed upstream

EcosystemPackageFixed in
RubyGemsactionpack6.1.7.9
RubyGemsactionpack7.0.8.5
RubyGemsactionpack7.1.4.1
RubyGemsactionpack7.2.1.1

Distro releases

ReleasePackageFixed in
Debian:11rails2:6.0.3.7+dfsg-2+deb11u3
Debian:12rails2:6.1.7.10+dfsg-1~deb12u1
Debian:13rails2:7.2.2.1+dfsg-1
Debian:14rails2:7.2.2.1+dfsg-1
Ubuntu:24.04:LTSrailsno fix
Ubuntu:25.10railsno fix
Ubuntu:26.04:LTSrailsno fix
Ubuntu:26.10railsno fix
Ubuntu:Pro:16.04:LTSrails2:4.2.6-1ubuntu0.1~esm1
Ubuntu:Pro:18.04:LTSrails2:4.2.10-0ubuntu4+esm1
Ubuntu:Pro:20.04:LTSrails2:5.2.3+dfsg-3ubuntu0.1~esm1
Ubuntu:Pro:22.04:LTSrails2:6.1.4.1+dfsg-8ubuntu2+esm1
openSUSE:Tumbleweedrubygem-actionpack-7.07.0.8.6-1.3
openSUSE:Tumbleweedrubygem-actionpack-7.07.0.8.6-1.1
openSUSE:Tumbleweedrubygem-rails-7.07.0.8.6-1.3
openSUSE:Tumbleweedrubygem-rails-7.07.0.8.6-1.1