Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-39877

Fixed in a distro release EPSS 2%CVSS 8.8

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Published 2024-07-17 · CVE record · OSV

Products: Apache Software Foundation Apache Airflow, Apache Airflow

Fixed upstream

EcosystemPackageFixed in
PyPIapache-airflow2.9.3

Distro releases

ReleasePackageFixed in
Chainguardairflow2.9.3-r0
Chainguardairflow-bitnami-compat2.9.3-r0
Chainguardairflow-compat2.9.3-r0
Wolfiairflow2.9.3-r0
Wolfiairflow-bitnami-compat2.9.3-r0
Wolfiairflow-compat2.9.3-r0