CVE-2024-37389
Fixed in a distro release EPSS 24%CVSS 4.6
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
Products: Apache Software Foundation Apache NiFi
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.nifi:nifi-web-ui | 1.27.0 |
| Maven | org.apache.nifi:nifi-web-ui | 2.0.0-M4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-nifi | 1.27.0-r0 |
| Chainguard | apache-nifi-compat | 1.27.0-r0 |
| Chainguard | apache-nifi-toolkit | 1.27.0-r0 |
| Wolfi | apache-nifi | 1.27.0-r0 |
| Wolfi | apache-nifi-compat | 1.27.0-r0 |
| Wolfi | apache-nifi-toolkit | 1.27.0-r0 |