CVE-2024-34340
Fixed in a distro release EPSS 1%CVSS 9.1
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password_hash` if there is it, else use `md5`. When verifying password, it calls `compat_password_verify`. In `compat_password_verify`, `password_verify` is called if there is it, else use `md5`. `password_verify` and `password_hash` are supported on PHP < 5.5.0, following PHP manual. The vulnerability is in `compat_password_verify`. Md5-hashed user input is compared with correct password in database by `$md5 == $hash`. It is a loose comparison, not `===`. It is a type juggling vulnerability. Version 1.2.27 contains a patch for the issue.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | cacti | 1.2.16+ds1-2+deb11u4 |
| Debian 12 | cacti | 1.2.24+ds1-1+deb12u3 |
| Debian 13 | cacti | 1.2.27+ds1-1 |
| Debian 14 | cacti | 1.2.27+ds1-1 |
| SUSE Package Hub 12 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 12 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP6 | cacti | 1.2.27-bp156.2.3.1 |
| SUSE Package Hub 15 SP6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| Ubuntu 20.04 LTS | cacti | 1.2.10+ds1-1ubuntu1.1 |
| Ubuntu 22.04 LTS | cacti | 1.2.19+ds1-2ubuntu1.1 |
| Ubuntu 24.04 LTS | cacti | 1.2.26+ds1-1ubuntu0.1 |
| Ubuntu Pro 14.04 LTS | cacti | 0.8.8b+dfsg-5ubuntu0.2+esm2 |
| Ubuntu Pro 16.04 LTS | cacti | 0.8.8f+ds1-4ubuntu4.16.04.2+esm2 |
| Ubuntu Pro 18.04 LTS | cacti | 1.1.38+ds1-1ubuntu0.1~esm3 |
| openSUSE Leap 15.5 | cacti | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.6 | cacti | 1.2.27-bp156.2.3.1 |
| openSUSE Leap 15.6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| openSUSE Tumbleweed | cacti | 1.2.27-1.1 |