Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-33522

Fixed in a distro release EPSS <1%CVSS 6.7

In vulnerable versions of Calico (v3.27.2 and below), Calico Enterprise (v3.19.0-1, v3.18.1, v3.17.3 and below), and Calico Cloud (v19.2.0 and below), an attacker who has local access to the Kubernetes node, can escalate their privileges by exploiting a vulnerability in the Calico CNI install binary. The issue arises from an incorrect SUID (Set User ID) bit configuration in the binary, combined with the ability to control the input binary, allowing an attacker to execute an arbitrary binary with elevated privileges.

Published 2024-04-29 · CVE record · OSV

Products: tigera calico, Tigera Calico Enterprise, Tigera Calico Cloud

Fixed upstream

EcosystemPackageFixed in
Gogithub.com/projectcalico/calico3.26.5
Gogithub.com/projectcalico/calico3.27.3
Gogithub.com/projectcalico/calicono fix
Gogithub.com/projectcalico/calico/v3no fix

Distro releases

ReleasePackageFixed in
Chainguardcalico0
Chainguardcalico-cni-fips-3.310
Chainguardcalico-fips0
Wolficalico0