CVE-2024-3209
Fixed in a distro release EPSS 1%CVSS 5.5
A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.
Products: upx, fedoraproject fedora
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | upx-ucl | 4.2.4-1 |
| Debian 14 | upx-ucl | 4.2.4-1 |
| Ubuntu 16.04 LTS | upx-ucl | no fix |
| Ubuntu 18.04 LTS | upx-ucl | no fix |
| Ubuntu 20.04 LTS | upx-ucl | no fix |
| Ubuntu 22.04 LTS | upx-ucl | no fix |
| Ubuntu 24.04 LTS | upx-ucl | no fix |
| Ubuntu 25.10 | upx-ucl | no fix |
| Ubuntu 26.04 LTS | upx-ucl | no fix |
| Ubuntu 26.10 | upx-ucl | no fix |