CVE-2024-31869
Fixed upstream EPSS 1%CVSS 5.3
Airflow versions 2.7.0 through 2.8.4 have a vulnerability that allows an authenticated user to see sensitive provider configuration via the "configuration" UI page when "non-sensitive-only" was set as "webserver.expose_config" configuration (The celery provider is the only community provider currently that has sensitive configurations). You should migrate to Airflow 2.9 or change your "expose_config" configuration to False as a workaround. This is similar, but different to CVE-2023-46288 https://github.com/advisories/GHSA-9qqg-mh7c-chfq which concerned API, not UI configuration page.
Products: Apache Software Foundation Apache Airflow
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | apache-airflow | 2.9.0 |