CVE-2024-31580
Fixed in a distro release EPSS <1%CVSS 4.0
PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.
Products: pytorch
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | torch | 2.2.0 |
| PyPI | torch | b5c3a17c2c207ebefcb85043f0cf94be9b2fef81 |
| PyPI | torch-npu | 2.2.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | pytorch | no fix |
| Debian 13 | pytorch | 2.4.1-1 |
| Debian 14 | pytorch | 2.4.1-1 |
| Ubuntu 22.04 LTS | pytorch | no fix |
| Ubuntu 25.10 | pytorch | no fix |
| Ubuntu 26.04 LTS | pytorch | no fix |
| Ubuntu 26.10 | pytorch | no fix |