CVE-2024-31459
Fixed in a distro release EPSS 3%CVSS 8.1
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, there is a file inclusion issue in the `lib/plugin.php` file. Combined with SQL injection vulnerabilities, remote code execution can be implemented. There is a file inclusion issue with the `api_plugin_hook()` function in the `lib/plugin.php` file, which reads the plugin_hooks and plugin_config tables in database. The read data is directly used to concatenate the file path which is used for file inclusion. Version 1.2.27 contains a patch for the issue.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | cacti | 1.2.16+ds1-2+deb11u4 |
| Debian 12 | cacti | 1.2.24+ds1-1+deb12u3 |
| Debian 13 | cacti | 1.2.27+ds1-1 |
| Debian 14 | cacti | 1.2.27+ds1-1 |
| SUSE Package Hub 12 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 12 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP6 | cacti | 1.2.27-bp156.2.3.1 |
| SUSE Package Hub 15 SP6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| Ubuntu 20.04 LTS | cacti | 1.2.10+ds1-1ubuntu1.1 |
| Ubuntu 22.04 LTS | cacti | 1.2.19+ds1-2ubuntu1.1 |
| Ubuntu 24.04 LTS | cacti | 1.2.26+ds1-1ubuntu0.1 |
| Ubuntu Pro 14.04 LTS | cacti | 0.8.8b+dfsg-5ubuntu0.2+esm2 |
| Ubuntu Pro 16.04 LTS | cacti | 0.8.8f+ds1-4ubuntu4.16.04.2+esm2 |
| Ubuntu Pro 18.04 LTS | cacti | 1.1.38+ds1-1ubuntu0.1~esm3 |
| openSUSE Leap 15.5 | cacti | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.6 | cacti | 1.2.27-bp156.2.3.1 |
| openSUSE Leap 15.6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| openSUSE Tumbleweed | cacti | 1.2.27-1.1 |