CVE-2024-31445
Fixed in a distro release EPSS 26%CVSS 8.8
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, a SQL injection vulnerability in `automation_get_new_graphs_sql` function of `api_automation.php` allows authenticated users to exploit these SQL injection vulnerabilities to perform privilege escalation and remote code execution. In `api_automation.php` line 856, the `get_request_var('filter')` is being concatenated into the SQL statement without any sanitization. In `api_automation.php` line 717, The filter of `'filter'` is `FILTER_DEFAULT`, which means there is no filter for it. Version 1.2.27 contains a patch for the issue.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | cacti | 1.2.16+ds1-2+deb11u4 |
| Debian 12 | cacti | 1.2.24+ds1-1+deb12u3 |
| Debian 13 | cacti | 1.2.27+ds1-1 |
| Debian 14 | cacti | 1.2.27+ds1-1 |
| SUSE Package Hub 12 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 12 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP6 | cacti | 1.2.27-bp156.2.3.1 |
| SUSE Package Hub 15 SP6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| Ubuntu 20.04 LTS | cacti | 1.2.10+ds1-1ubuntu1.1 |
| Ubuntu 22.04 LTS | cacti | 1.2.19+ds1-2ubuntu1.1 |
| Ubuntu 24.04 LTS | cacti | 1.2.26+ds1-1ubuntu0.1 |
| Ubuntu Pro 14.04 LTS | cacti | 0.8.8b+dfsg-5ubuntu0.2+esm2 |
| Ubuntu Pro 16.04 LTS | cacti | 0.8.8f+ds1-4ubuntu4.16.04.2+esm2 |
| Ubuntu Pro 18.04 LTS | cacti | 1.1.38+ds1-1ubuntu0.1~esm3 |
| openSUSE Leap 15.5 | cacti | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.6 | cacti | 1.2.27-bp156.2.3.1 |
| openSUSE Leap 15.6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| openSUSE Tumbleweed | cacti | 1.2.27-1.1 |