CVE-2024-3116
Fixed in a distro release EPSS 66%CVSS 7.4
pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.
Products: pgadmin.org pgAdmin 4, postgresql pgadmin_4
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | pgadmin4 | 8.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Tumbleweed | pgadmin4 | 8.5-1.1 |