CVE-2024-29894
Fixed in a distro release EPSS <1%CVSS 5.4
Cacti provides an operational monitoring and fault management framework. Versions of Cacti prior to 1.2.27 contain a residual cross-site scripting vulnerability caused by an incomplete fix for CVE-2023-50250. `raise_message_javascript` from `lib/functions.php` now uses purify.js to fix CVE-2023-50250 (among others). However, it still generates the code out of unescaped PHP variables `$title` and `$header`. If those variables contain single quotes, they can be used to inject JavaScript code. An attacker exploiting this vulnerability could execute actions on behalf of other users. This ability to impersonate users could lead to unauthorized changes to settings. Version 1.2.27 fixes this issue.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | cacti | 1.2.24+ds1-1+deb12u3 |
| Debian 13 | cacti | 1.2.27+ds1-1 |
| Debian 14 | cacti | 1.2.27+ds1-1 |
| SUSE Package Hub 12 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 12 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP6 | cacti | 1.2.27-bp156.2.3.1 |
| SUSE Package Hub 15 SP6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| Ubuntu 20.04 LTS | cacti | 1.2.10+ds1-1ubuntu1.1 |
| Ubuntu 22.04 LTS | cacti | 1.2.19+ds1-2ubuntu1.1 |
| Ubuntu 24.04 LTS | cacti | 1.2.26+ds1-1ubuntu0.1 |
| Ubuntu Pro 14.04 LTS | cacti | 0.8.8b+dfsg-5ubuntu0.2+esm2 |
| Ubuntu Pro 16.04 LTS | cacti | 0.8.8f+ds1-4ubuntu4.16.04.2+esm2 |
| Ubuntu Pro 18.04 LTS | cacti | 1.1.38+ds1-1ubuntu0.1~esm3 |
| openSUSE Leap 15.5 | cacti | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.6 | cacti | 1.2.27-bp156.2.3.1 |
| openSUSE Leap 15.6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| openSUSE Tumbleweed | cacti | 1.2.27-1.1 |