Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-27135

Fixed upstream EPSS 6%CVSS 8.5

Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Published 2024-03-12 · CVE record · OSV

Products: Apache Software Foundation Apache Pulsar, apache pulsar

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.pulsar:pulsar-functions-worker2.10.6
Mavenorg.apache.pulsar:pulsar-functions-worker2.11.4
Mavenorg.apache.pulsar:pulsar-functions-worker3.0.3
Mavenorg.apache.pulsar:pulsar-functions-worker3.1.3
Mavenorg.apache.pulsar:pulsar-functions-worker3.2.1