CVE-2024-27082
Fixed in a distro release EPSS <1%CVSS 7.6
Cacti provides an operational monitoring and fault management framework. Versions of Cacti prior to 1.2.27 are vulnerable to stored cross-site scripting, a type of cross-site scripting where malicious scripts are permanently stored on a target server and served to users who access a particular page. Version 1.2.27 contains a patch for the issue.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | cacti | 1.2.24+ds1-1+deb12u5 |
| Debian 13 | cacti | 1.2.27+ds1-1 |
| Debian 14 | cacti | 1.2.27+ds1-1 |
| SUSE Package Hub 12 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 12 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| SUSE Package Hub 15 SP6 | cacti | 1.2.27-bp156.2.3.1 |
| SUSE Package Hub 15 SP6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| Ubuntu 24.04 LTS | cacti | no fix |
| Ubuntu 25.10 | cacti | no fix |
| Ubuntu 26.04 LTS | cacti | no fix |
| Ubuntu 26.10 | cacti | no fix |
| Ubuntu Pro 14.04 LTS | cacti | no fix |
| Ubuntu Pro 16.04 LTS | cacti | no fix |
| Ubuntu Pro 18.04 LTS | cacti | no fix |
| Ubuntu Pro 20.04 LTS | cacti | no fix |
| Ubuntu Pro 22.04 LTS | cacti | no fix |
| openSUSE Leap 15.5 | cacti | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.5 | cacti-spine | 1.2.27-bp155.2.9.1 |
| openSUSE Leap 15.6 | cacti | 1.2.27-bp156.2.3.1 |
| openSUSE Leap 15.6 | cacti-spine | 1.2.27-bp156.2.3.1 |
| openSUSE Tumbleweed | cacti | 1.2.27-1.1 |