CVE-2024-2660
Fixed in a distro release EPSS <1%CVSS 6.4
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
Products: HashiCorp Vault, HashiCorp Vault Enterprise
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/hashicorp/vault | 1.16.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | k3d | 5.6.0-r11 |
| Chainguard | k3d-proxy | 5.6.0-r11 |
| Chainguard | k3d-tools | 5.6.0-r11 |
| Chainguard | vault-1.16 | 0 |
| Chainguard | vault-1.16-compat | 0 |
| Chainguard | vault-fips-1.14 | 1.14.11-r0 |
| Chainguard | vault-fips-1.16 | 0 |
| Chainguard | vault-fips-1.16-compat | 0 |
| Wolfi | k3d | 5.6.0-r11 |
| Wolfi | k3d-proxy | 5.6.0-r11 |
| Wolfi | k3d-tools | 5.6.0-r11 |
| openSUSE:Tumbleweed | sops | 3.9.0-1.1 |