Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-25641

Fixed in a distro release EPSS 86%CVSS 9.1

Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, an arbitrary file write vulnerability, exploitable through the "Package Import" feature, allows authenticated users having the "Import Templates" permission to execute arbitrary PHP code on the web server. The vulnerability is located within the `import_package()` function defined into the `/lib/import.php` script. The function blindly trusts the filename and file content provided within the XML data, and writes such files into the Cacti base path (or even outside, since path traversal sequences are not filtered). This can be exploited to write or overwrite arbitrary files on the web server, leading to execution of arbitrary PHP code or other security impacts. Version 1.2.27 contains a patch for this issue.

Published 2024-05-13 · CVE record · OSV

Products: cacti, the_cacti_group cacti

Distro releases

ReleasePackageFixed in
Debian 11cacti1.2.16+ds1-2+deb11u4
Debian 12cacti1.2.24+ds1-1+deb12u3
Debian 13cacti1.2.27+ds1-1
Debian 14cacti1.2.27+ds1-1
SUSE Package Hub 12cacti1.2.27-bp155.2.9.1
SUSE Package Hub 12cacti-spine1.2.27-bp155.2.9.1
SUSE Package Hub 15 SP5cacti1.2.27-bp155.2.9.1
SUSE Package Hub 15 SP5cacti-spine1.2.27-bp155.2.9.1
SUSE Package Hub 15 SP6cacti1.2.27-bp156.2.3.1
SUSE Package Hub 15 SP6cacti-spine1.2.27-bp156.2.3.1
Ubuntu 20.04 LTScacti1.2.10+ds1-1ubuntu1.1
Ubuntu 22.04 LTScacti1.2.19+ds1-2ubuntu1.1
Ubuntu 24.04 LTScacti1.2.26+ds1-1ubuntu0.1
Ubuntu Pro 14.04 LTScacti0.8.8b+dfsg-5ubuntu0.2+esm2
Ubuntu Pro 16.04 LTScacti0.8.8f+ds1-4ubuntu4.16.04.2+esm2
Ubuntu Pro 18.04 LTScacti1.1.38+ds1-1ubuntu0.1~esm3
openSUSE Leap 15.5cacti1.2.27-bp155.2.9.1
openSUSE Leap 15.5cacti-spine1.2.27-bp155.2.9.1
openSUSE Leap 15.6cacti1.2.27-bp156.2.3.1
openSUSE Leap 15.6cacti-spine1.2.27-bp156.2.3.1
openSUSE Tumbleweedcacti1.2.27-1.1