CVE-2024-24826
Fixed in a distro release EPSS <1%CVSS 5.5
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 version v0.28.1. The vulnerable function, `QuickTimeVideo::NikonTagsDecoder`, was new in v0.28.0, so Exiv2 versions before v0.28 are _not_ affected. The out-of-bounds read is triggered when Exiv2 is used to read the metadata of a crafted video file. In most cases this out of bounds read will result in a crash. This bug is fixed in version v0.28.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Products: exiv2
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | exiv2 | 0.16.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux 2 | exiv2 | 0.27.0-4.amzn2.0.5 |
| Amazon Linux 2 | exiv2-devel | 0.27.0-4.amzn2.0.5 |
| Amazon Linux 2 | exiv2-doc | 0.27.0-4.amzn2.0.5 |
| Amazon Linux 2 | exiv2-libs | 0.27.0-4.amzn2.0.5 |
| Debian 12 | exiv2 | no fix |
| Debian 13 | exiv2 | 0.28.3+dfsg-2 |
| Debian 14 | exiv2 | 0.28.3+dfsg-2 |
| SUSE Linux Enterprise Server 16.0 | exiv2 | 0.28.8-160000.1.1 |
| SUSE Linux Enterprise Server for SAP applications 16.0 | exiv2 | 0.28.8-160000.1.1 |
| openSUSE Leap 16.0 | exiv2 | 0.28.8-160000.1.1 |
| openSUSE Tumbleweed | exiv2 | 0.28.2-1.1 |