CVE-2024-24479
Fixed in a distro release EPSS 1%CVSS 7.5
A Buffer Overflow in Wireshark before 4.2.0 allows a remote attacker to cause a denial of service via the wsutil/to_str.c, and format_fractional_part_nsecs components. NOTE: this is disputed by the vendor because neither release 4.2.0 nor any other release was affected.
Products: wireshark, fedoraproject fedora
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux 2023 | wireshark-cli | 1:4.4.2-1.amzn2023.0.1 |
| Amazon Linux 2023 | wireshark-devel | 1:4.4.2-1.amzn2023.0.1 |
| Ubuntu 20.04 LTS | wireshark | no fix |
| Ubuntu 22.04 LTS | wireshark | no fix |
| Ubuntu 24.04 LTS | wireshark | no fix |
| Ubuntu Pro 14.04 LTS | wireshark | no fix |
| Ubuntu Pro 16.04 LTS | wireshark | no fix |
| Ubuntu Pro 18.04 LTS | wireshark | no fix |