CVE-2024-23807
Fixed in a distro release EPSS 1%CVSS 8.1
The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs. Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCES_DISABLE_DTD environment variable. This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.
Products: Apache Software Foundation Apache Xerces C++, apache xerces-c\+\+
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux 2 | xerces-c | 3.1.1-10.amzn2.0.2 |
| Amazon Linux 2 | xerces-c-devel | 3.1.1-10.amzn2.0.2 |
| Amazon Linux 2 | xerces-c-doc | 3.1.1-10.amzn2.0.2 |
| Ubuntu 22.04 LTS | xerces-c | 3.2.3+debian-3ubuntu0.1 |
| Ubuntu Pro 16.04 LTS | xerces-c | 3.1.3+debian-1ubuntu0.1~esm2 |
| Ubuntu Pro 18.04 LTS | xerces-c | 3.2.0+debian-2ubuntu0.1~esm2 |
| Ubuntu Pro 22.04 LTS | xerces-c | 3.2.3+debian-3ubuntu0.1~esm1 |