Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-22371

Fixed upstream EPSS <1%CVSS 2.9

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

Published 2024-02-26 · CVE record · OSV

Products: Apache Software Foundation Apache Camel

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.camel:camel-core3.21.4
Mavenorg.apache.camel:camel-core3.22.1
Mavenorg.apache.camel:camel-core4.0.4
Mavenorg.apache.camel:camel-core4.4.0