Patchwire CVEs, their patch status, and feeds to follow them

CVE-2024-22369

Fixed upstream EPSS <1%CVSS 7.8

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Published 2024-02-20 · CVE record · OSV

Products: Apache Software Foundation Apache Camel, apache camel

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.camel:camel-sql3.21.4
Mavenorg.apache.camel:camel-sql3.22.1
Mavenorg.apache.camel:camel-sql4.0.4
Mavenorg.apache.camel:camel-sql4.4.0