CVE-2024-22233
Fixed in a distro release EPSS 1%CVSS 7.5
In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: * the application uses Spring MVC * Spring Security 6.1.6+ or 6.2.1+ is on the classpath Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.
Products: Spring Framework
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework:spring-core | 6.1.3 |
| Maven | org.springframework:spring-core | 6.0.16 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | jenkins | 2.442-r0 |
| Chainguard | jenkins-compat | 2.442-r0 |
| Chainguard | jenkins-remoting | 2.442-r0 |
| Wolfi | jenkins | 2.442-r0 |
| Wolfi | jenkins-compat | 2.442-r0 |
| Wolfi | jenkins-remoting | 2.442-r0 |