CVE-2024-21501
Fixed in a distro release EPSS 1%CVSS 5.3
Versions of the package sanitize-html before 2.12.1 are vulnerable to Information Exposure when used on the backend and with the style attribute allowed, allowing enumeration of files in the system (including project dependencies). An attacker could exploit this vulnerability to gather details about the file system structure and dependencies of the targeted server.
Products: apostrophecms sanitize-html
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | sanitize-html | 2.12.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | jupyter-base-notebook | 7.6.3-r2 |
| Chainguard | py3.10-jupyterlab | 4.6.1-r1 |
| Chainguard | py3.11-jupyterlab | 4.6.1-r1 |
| Chainguard | py3.12-jupyterlab | 4.6.1-r1 |
| Chainguard | py3.13-jupyterlab | 4.6.1-r1 |
| Chainguard | tensorflow-cpu-jupyter | 2.21.0-r8 |
| Debian 12 | node-sanitize-html | no fix |
| Debian 13 | node-sanitize-html | 2.13.0+~2.11.0-1 |
| Debian 14 | node-sanitize-html | 2.13.0+~2.11.0-1 |
| Ubuntu 22.04 LTS | node-sanitize-html | no fix |
| Ubuntu 24.04 LTS | node-sanitize-html | no fix |
| Ubuntu 25.10 | node-sanitize-html | no fix |
| Ubuntu 26.04 LTS | node-sanitize-html | no fix |
| Ubuntu 26.10 | node-sanitize-html | no fix |
| Wolfi | jupyter-base-notebook | 7.6.3-r2 |
| Wolfi | py3.10-jupyterlab | 4.6.1-r1 |
| Wolfi | py3.11-jupyterlab | 4.6.1-r1 |
| Wolfi | py3.12-jupyterlab | 4.6.1-r1 |
| Wolfi | py3.13-jupyterlab | 4.6.1-r1 |