CVE-2024-21166
Fixed in a distro release EPSS <1%CVSS 5.9
Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 8.0.36 and prior and 8.3.0 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Server accessible data and unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 5.9 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:H).
Products: Oracle Corporation MySQL Server, Oracle MySQL Server
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | mysql-8.0 | 8.0.38-r0 |
| Ubuntu 14.04 LTS | mysql-5.5 | no fix |
| Ubuntu 16.04 LTS | percona-server-5.6 | no fix |
| Ubuntu 16.04 LTS | percona-xtradb-cluster-5.6 | no fix |
| Ubuntu 20.04 LTS | mysql-8.0 | 8.0.37-0ubuntu0.20.04.3 |
| Ubuntu 22.04 LTS | mysql-8.0 | 8.0.37-0ubuntu0.22.04.3 |
| Ubuntu 24.04 LTS | mysql-8.0 | 8.0.37-0ubuntu0.24.04.1 |
| Ubuntu Pro 16.04 LTS | mysql-5.7 | no fix |
| Ubuntu Pro 18.04 LTS | mysql-5.7 | no fix |